UAC issues

Aug 9, 2013 at 9:56 AM
Hello!

I've read homepage about Access Denied exception when running ldtp without admin privileges on Win 7 but would like to confirm my fears :)

I use python bindings so (as I get it) on 'import ldtp' in my scripts the service is started. Is it possible at all to somehow make it work with UAC turned on? I can't run the script itself as admin because the application that I need to test shows UAC prompts and we need to check for that.

Maybe some way to import ldtp as admin and then use it in tests without admin privileges?

Thank you.
Coordinator
Aug 9, 2013 at 5:01 PM
Hello Tirene,

Did you get a chance to try with https://github.com/ldtp/cobra#using-cobra ?

Thanks
Nagappan
Aug 9, 2013 at 5:09 PM
Yes, I meant exactly this.

Disabling ACL is not an option for us. As for listening to all interfaces - is it necessary? I am happy with localhost as long as service doesn't crash.
Still, I tried netsh http add urlacl url=http://localhost:4118/ user=User - got wrong username error or smth like that. Changing to my current username didn't help.
Coordinator
Aug 9, 2013 at 7:42 PM
Its not necessary to listen all interfaces, just 4118 should be good and that too on localhost is fine, as long as you plan to run the test from localhost. @VMware, we have verified just with localhost and it have worked. Thanks